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Predgovor 

Tema završnog rada je proces izrade game ready modela gdje će se pokazati znanje 3D 

modeliranja, uređivanje UV mapa, izrada mapa tekstura za PBR tok i na kraju samo teksturiranje. 

Rad je zamišljen u 2 dijela, prvi gdje će se teoretski obrazložiti važniji aspekti kako bi bila moguća 

izrada modela te drugi dio gdje se vrijeme posvećuje izradi modela. 



 

Sažetak 

Fokus završnog rada biti će na izradi optimiziranog game ready asseta gdje će se proći kroz 

razne podteme i osnove 3D modeliranja, izrade UV mapa, bake procesa i teksturiranja modela. 

Važno je proći kroz sve navedene aspekte kako bi se mogao izraditi optimizirani game ready asset 

koji neće naštetiti ili nepotrebno opteretiti game engine. Vidjet će se i pokazati znanja Autodesk 

Maye 2019, korištenje programa Marmoset Toolbag 3 te jednog od novijih programa pod nazivom 

Quixel Mixer za teksturiranje modela.  

 

U praktičnom dijelu izraditi će se game ready asset u obliku radničkih svjetla te bi se na taj način 

povezala navedena teorija sa vizualnim primjerom cijelog procesa.  

 

Ključne riječi: 3D modeliranje, UV mapiranje, Baking proces, Teksturiranje, Autodesk Maya, 

Marmoset Toolbag 3, Quixel Mixer 

  



 

Summary 

Focus of the final paper will be about creating an optimised game ready asset. In order to 

accomplish that, the basic knowledge of 3D modelling, UV mapping, baking process and texturing 

will be explained. It is important to go through all the steps mentioned above so an optimized game 

ready asset could be built, otherwise the game engine could possibly have a hard time of using the 

object, it could easily drain it's memory and thus make it have bad FPS problems. Through the 

process, knowledge of Autodesk Maya 2019, Marmoset Toolbag 3 and Quixel Mixer will be 

shown.  

 

In the practical part of the thesis the model itself will be made, step by step, so the theory and 

practice could be integrated for better understanding of the whole process in question.  

 

Keywords: 3D modelling, UV mapping, Baking process, Texturing, Autodesk Maya, Marmoset 

Toolbag 3, Quixel Mixer 

  



 

Popis korištenih kratica 

3D Trodimenzionalno 

Kratica označuje treću dimenziju  

 

2D Dvodimenzionalno 

Kratica označuje drugu dimenziju 

 

MT3 Marmoset Toolbag 3 

Kratica označuje program za bake tekstura 

 

QM Quixel Mixer 

Kratica označuje program za teksturiranje 

 

GE Game engine 

Kratica označuje pokretača videoigre 

 

LOD Level of detail 

Kratica označuje razinu detalja na modelu 

 

VB-LOD View Based – Level of detail 

Kratica označuje jedan od mogućih načina rada razine detalja 

 

AO Ambient occlusion 

Kratica označuje jednu od mapa za izradu tekstura koja predstavlja ambijentalnu 

okluziju  

 

RGB Red Green Blue 

Kratica označuje navedeni spektar boja  
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Uvod 

Bit završnog rada je prikazati proces izrade game ready asseta te opisati način razmišljanja pri 

samoj izradi modela, kako nebi došlo do neželjenih posljedica. Važno je unaprijed znati gdje 

posvetiti pažnju kako bi se mogao izraditi optimizirani model za nekoji game engine.  

 

U teoretskom dijelu će se detaljno proći kroz osnove 3D modeliranja, raznih tematika vezanih uz 

3D i optimizaciju modela.  

 

Sa teoretskim znanjem u drugom dijelu završnog rada proći će se izrada modela u programu 

Autodesk Maya 2019, i njezini alati. Također će pažnja biti na načinu na koji se optimizira model 

pri izradi tako da kvalitetno izgleda, no da se izbjegne moguće opterećenje game enginea u isto 

vrijeme. Opisati će se proces bakea normala kojim se na low poly modelu može pokazati visoka 

kvaliteta dok je polycount smanjen na minimum radi optimizacije. Na samom kraju završnog rada 

će se model teksturirati u programu Quixel Mixer.  

 

Ovim radom se želi pokazati znanje izrade visokokvalitetnog i optimiziranog modela sa kojim će 

game engine moći besprijekorno raditi. 
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1. 3D modeliranje 

1.1. Terminologija potrebna za izradu 3D modela 

Svaka računalno-renderana slika zahtijeva tri osnovne komponente: 3D scenu, nekoliko izvora 

svjetla i kamere pomoću kojih se snima scena. Scena se najčešće sastoji od jednog ili više modela. 

[1] 

Na slici se mogu uočiti sve nabrojene komponente, 

1. Scena, i njezin glavni detalj 

2. Izvori svjetla koji dolaze iza kamere, te komponente modela koje pomoću emission mape daju 

specifičnost glavnom modelu. 

3. Kamera kojom je slika prvobitno izrađena [1, 9] 

 

Slika 1-1: Prikaz scene 

 

Na model gledamo kao samostalan dio, kao što je naprimjer stol, kuća, auto i slični, te 

zahvaljujući tim modelima i njihovim vezama stvara se 3D scena,  tj. nastaje i oni grade 3D 

okruženje u kojem se nalaze. Spomenuto je zapravo, najuobičajeniji princip izrade 3D scene: 
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izrađuje se nekoliko modela, a kasnije, zahvaljujući njima, nastaje scena. [1] 

 

Slika 1-2: Primjer različitih modela 

Svaki model se može opisati na dvaju načina: 

 

                        1. Matematičkim prikazom same strukture oblika, 

 

Slika 1-3: Struktura oblika 
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Slika 1-5: Prikaz prejednostavno izrađenog 

modela 

2. Načinom pomoću kojeg se prikazuje kako svjetlo, i koje, ima utjecaj na određeni model [1] 

 

Slika 1-4: Utjecaj svjetla na model 

1.2. Važnost detalja i njihov utjecaj na izradu kvalitetnog modela 

Detalji čine model zanimljivijim za gledatelje/korisnike, time se može zaključiti da količina 

detaljnosti pri izradi modela vrlo brzo može imati jedan od dvaju efekta [1]: 

1. Dosadan i nerealističan 
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Slika 1-6: Prikaz kvalitetno izrađenog modela 

Slika 1-7: Prikaz similarnosti 3D izgrađenog 

modela i realnog objekta 

   2.  Realističan i intrigantan 

 

 

U počecima korištenja 3D modela postojali su većinom ekstremno jednostavni modeli, 

gdje bi na primjer stol predstavljala nekakva kutija koja se sastoji od 6 perfektno ravnih, izglađenih 

i obojenih strana. Pošto savršeno u realnom svijetu ne postoji, ukoliko se želi izraditi zanimljiv i 

vjerodostojan model, potrebno je za njega da izgleda dovoljno obogaćen detaljima kako bi što 

bliže odgovarao kompleksnosti objekta iz realnog svijeta. [1] 
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Ako se općenito spominje *detalj*, više dodanih detalja u geometriji, poput udubina, 

ogrebotina i sličnih, direktno daje modelu kvalitetniji i realniji izgled.    

 

Usprkos tome postoje dva problema [1]:  

 

1. Više detalja znači više utrošenog vremena prilikom samog dizajna  

2. Računalu, to jest rendereru duže treba da procesira sve detalje na objektima  

1.3. Načini modeliranja 

U današnje vrijeme postoji nekoliko programa koji pomažu pri izradi modela, njih se najčešće 

naziva modelerima. Iako postoje različiti programi, princip izrade modela je vrlo sličan u svima. 

[1] 

 

Slika 1-8: Prikaz modela i mreže 

1.3.1. Interaktivni način modeliranja 

Za interaktivni način izrade modela, programi dolaze sa raznim pomagalima/alatima koji 

pomažu dizajneru da postigne određenu preciznost. Primjeri takvih jednostavnih funkcija su snap 

to vertex, snap to grid i slični. [1] 
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Slika 1-10: Prikaz Move Tool-a (1.); Prikaz Rotate Tool-a(2.); Prikaz alata za 

kloniranje objekta (3.) 

 

 

 

Modeli su građeni interaktivnim selektiranjem, kreiranjem, izmjenom, prilagodbom te 

sastavljanjem instanca primitivnih oblika. Oblici imaju takozvane „ručke“ kojima modeler definira 

istog. One dolaze u obliku pointova (za npr. pomicanje objekta), curveova (okretanje objekta) i 

interaktivnih alata (izrada udubina, izbočina i ostalih). [1] 

 

 

Slika 1-9: Primjer funkcije 

Snap to Grid 
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Slika 1-11: Prikaz korištenja skripte unutar programa Autodesk Maya 

1.3.2. Skriptna izrada modela 

U skriptnom načinu izrade se koriste skripte kako bi se definirao oblik modela. Skripta se 

smatra tekstnim dokumentom koji je bio izrađen od strane dizajnera koristeći bilo koji text editor. 

Skripta određuje oblike modela, identificirajući parametre koji su upisani u skripti kako bi trebala 

određena instanca izgledati. Pošto se time mogu operacije točno opisati numeričkim izrazima,za 

razliku od interaktivnog načina, oni su idealni za izradu vrlo preciznih modela. [1]   
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1.4. Primitivni oblici/modeli 

1.4.1. Osnove 

Ako se uzme kao primjer kocka, ona se sastoji od 6 polygona, unutrašnji dio polygona 

najčešće se naziva terminom „face“.  

 

Slika 1-12: Prikaz lica 

Linije koje se nalaze na granicama jednog polygona, to jest na rubovima, zovu se „Edge“-ovi  

 

Slika 1-13: Prikaz bridova 
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Još jedino što je ostalo su uglovi na kojima se mogu uočiti točke kojima su naziv 

„Vertices(množina),vertex(jednina)“. [11] 

 

Slika 1-14: Prikaz vertexa 

 

Kako bi se shvatile dimenzije potrebno je detaljno opisati proces dobitka nekakvog primitivnog 

3D modela. Kocka se sastoji od triju dimenzija: dužine, širine i visine. Nakon nje ako se 

pogleda jedno njezino lice, to jest jedan njezin polygon, može se vidjeti da se ono sastoji od 

samo dvije dimenzije: širine i dužine. Jedan brid se sastoji od samo jedne dimenzije: dužine, 

dok na samom kraju postoji vertex, točka koja sama nema dimenziju. [3]  

 

Polygoni nemoraju nužno izgledati kao kvadrati. Mogu se sastojati od bilo koliko bridova i 

točaka, uz pravilo da je najmanji mogući broj troje točaka/bridova pošto one predstavljaju 

najmanji oblik poylgona; tris, to jest trokut. Ovdje je važno spomenuti, pošto su oni toliko 

jednostavni, olakšavaju game engineu rad, pogotovo u situacijama kada se mnogo toga dešava 

u videoigri u isto vrijeme. [11] 



11 

 

 

Slika 1-15: Prikaz trisa 

 

Četverostrani polygoni, koji su najčešći u izradi modela, se zovu „Quad“-ovi što je skraćenica 

od termina „Quadrangle“. Oni su odlični pri izradi, pošto je sa njima lako raditi, slažu se uredno 

po mreži i uz to kako bi ih pretvorili u trisove, što se događa prilikom importanja modela u game 

engine, potrebno je GE da samo „povuče“ dijagonalu preko quada kako bi dobio trisove. Iz 

navedenih razloga većina 3D umjetnika preporuča korištenje quadova ko osnovni oblik za rad s 

polygonima. [11] 
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Slika 1-16: Prikaz quadranglea 

Još je potrebno spomenuti n-gone koji se daleko ne smiju pojavljivat ili koristiti, n-gonima se 

nazivaju svi polygoni koji imaju 5 ili više bridova/vertexa. Računalo sa njima ima velik problem 

pošto su oni ekstremno teški GE za rad, iz razloga što ih game engine smatra vrlo kompliciranima. 

[11] 

 

Slika 1-17: Prikaz n-gona 
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1.4.2. Planar i non/planar polygoni 

U matematici plohe nemaju krivulje, potom se trokut može nalaziti samo na jednoj plohi, taj 

trokut se naziva planarnim. Quadovi i n-goni mogu, i trebali bi biti također samo planarni. No u 

njihovom slučaju se jedna točka, tj. jedan kut može saviti što zauzvrat čini taj određeni quad ili n-

gon non-planar polygonom. Većinom to predstavlja problem jer veći postotak aplikacija neće moći 

shvatiti kako da se odnose prema spomenutom polygonu. U vrijeme današnjice većina programa 

iz tog razloga ima automatsko riješenje u kojem takav tip polygona sječe na trisove koje kasnije 

lakše obrađuje. [11] 

 

1.5. Real time based rendering i modelling 

1.5.1. Real-time base rendering 

Princip rada real time rendera odnosi se na način rada gdje sistem instantno reagira na promjene 

inputa. Koriste se za stvari kao što je navigacija, pri kojem računalo mora reagirati na stalni protok 

novih informacija bez ometanja. Real time se također odnosi na događaje koji su simulirani 

računalom istom brzinom kojom bi se dovijali u stvarnom životu. [2] 

Slika 1-18: Prikaz planarnog i neplanarnog poligona 
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Slika1-20: Prikaz teksture 

 

Slika 1-19: Prikaz scene iz game enginea 

1.5.2. Modeliranje za real-time based engine 

Modeliranje je ključni problem i jedan od najkritičnijih djelova pri izradi asseta za aplikacije 

koje koriste real-time rendering. Kako bi real-time aplikacija nesmetano radila, te pošto ona ovisi 

o brzini kako bi se video igru moglo nesmetano koristiti, grafika te vrste renderanja ima veliki 

utjecaj. Ovdje dolazi do problema gdje bi pre-renderani modeli trebali izgledat što više realistično, 

dok bi u isto vrijeme trebalo optimizirati modele tako da renderer ne trpi previše novih podataka 

u isto vrijeme, već da je render što brži mogući. [2] 
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Kako bi to bilo moguće, što se tiče izrade modela, real time render bi trebalo optimizirati sa 

modelima koji imaju samo najpotrebnije elemente poput glavnih detalja koji opisuju model 

ekskluzivno na low polyu, [2] 

 

 

Slika 1-21: Prikaz low poly izrade modela 

 

dok bi se ostali detalji, koji pomažu pri izradi realnijeg izgleda, nadodali uz pomoć tekstura i 

high poly bake-a normala. [2] 

 

 

 

 

 

 

 

 

 Slika 1-22: Prikaz kasnije high poly verzije i normal mape koja je proizašla iz 

nje 
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1.6. Level of detail 

LOD tehnike se konstantno sve više i više upotrebljavaju kod izrade real-time rendered modela 

kako bi se postigao balans između lijepog izgleda videoigre i glatke, neometane animacije. Već 

spomenuta metoda je potrebna kako bi se dobila brzina i optimizirala videoigra. Njih se može 

smatrati „stand in“ objektima koji reagiraju/se zamjenjuju sa svojim higher/lower poly instancama 

ovisno o korisnikovom stajalištu, tj. ovisno koliko su blizini kamere. Tim načinom kada je 

primjerice objekt bliži igraču/korisniku, on vidi model u njegovoj najvišoj rezoluciji te dobija 

odličan dojam kvalitete igre, no u isto vrijeme kada bi se isti odmaknuo od objekta, te kad bi objekt 

zauzimao mali prostor na ekranu i bio u daljini na mjestu modela visoke rezolucije bi se stvorila 

instanca modela koja se sastoji od puno manjeg poly counta. [4] 

 

Slika 1-23: Prikaz korištenja raznih LODa jednog modela u praksi 

 

Iako ova tehinka jako pomaže pri optimizaciji videoigre, od dizajnerske strane se očekuje da 

se izrade isti modeli sa različitim nivoima detalja što iziskuje dosta utrošenog vremena. [4] 

1.6.1. Diskretan LOD 

Znana još kao i tradicionalna shema koju je predložio J. Clark 1976. te se još uvijek i danas 

koristi, ovaj način izrade je da se napravi nekoliko verzija svakog objekta, svaku od instanca na 

svojem osobnom poly countu. Prilikom pokretanja određeni LOD je odabran kako bi reprezentirao 

neki objekt. Pošto udaljeni modeli koriste grublje LOD-se općeniti broj polygona je smnjen te se 

na taj način optimizira render videoigre. Pošto se LOD određuje prije, to jest offline, u fazi 
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pretprocesiranja, proces simplifikacije nemože predvidjeti stranu iz koje će kamera gledati. Iz tog 

razloga simplifikacija kod ove vrste najčešće smanjuje detalje jednoliko preko cijelog objekta. 

Zbog toga diskretan LOD dobija naziv isotropski ili view-independent LOD. [4] 

 

1.6.2. Kontinuirani LOD 

Glavna prednost ovog pristupa je ta što je razina detalja za svaki objekt precizno određena, 

rađe nego da je odabrana iz nekoliko prije kreiranih opcija što mu daje prednost iz razloga jer se 

ne koristi više nego potrebno polygona. Zahvaljujući tome se oslobađaju polygoni koji bi možda 

bili korisniji na nekom od ostalih modela, time se bolje mogu iskoristiti dani resursi i zagarantirano 

je općenito smanjenje broja polygona. [4] 

1.6.3. View-based LOD 

Najnoviji način opmtimizacije, VB-LOD ima kriterij simplifikacije prema daljini kamere, to 

jest on dinamički selektira najbolje odgovarajuće LOD razine svakih od objekata za trenutnu 

udaljenost igrača od individualnog objekta kojega se vidi. Stoga se view-dependent LOD smatra 

anizotropski, gdje neki objekt se može prostirati kroz nekoliko razina simplifikacije. Kao primjer, 

dijelovi objekta koji su bliže mogu biti prikazani u višoj rezoluciji nego njegovi dijelovi koji se 

nalaze u daljini. Time se poligoni raspoređuju tamo gdje su daleko najpotrebniji u samom modelu 

te i između tog modela sa ostalim objektima. Bez nje optimizacija primjerice fizički velikih 

modela, poput terena na kojem se korisnik nalazi, bi bila vrlo zahtijevna za optimizaciju. [4] 

 

1.7. Modeliranje i polycount 

Poly count se smatra brojem količine polygona kod određenog modela. Iako je u suštini to 

jednostavno za shvatiti on zapravo definira svaki model, te je unaprijed važno razmišljati o njemu 

kako bi se poligoni nekog modela kvalitetnije mogli rasporediti, tako da se nađe sredina između 

kvalitete i optimiziranog modela. Prilikom izrade najčešće postoje restrikcije na poly countu za 

model, zbog toga na nekim mjestima se slobodno quadovi režu i trisove  kako bi se izbjegao 

prevelik broj polygona. U vrijeme sadašnjice nekakva idealna rezolucija za model nekakvog lika 
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je u granicama 1500-4000 (low poly model) polygona, sa eventualnim pomakom do 7000 kod 

videoigara izrađenih za high-end računala. [6,7]  

 

 

Slika 1-24: Prikaz polycountera u Autodesk Mayi 

1.7.1. High poly model 

High poly princip modeliranja se može smatrati modeliranjem bez limitacija poly counta. Taj  

tip modela je u suštini složen i vrlo detaljan. Kreirani modeli služe za izradu mapa i dodavanje 

detalja pomoću bake tehnike.  [4,12]  

 

To znači da modeli smiju imati koliko god detalja 3D umjetnik zaželi, pošto neće utjecati na brzinu 

same videoigre, moglo bi se reči da je jedina granica izrade high poly modela vještine samog 

artista, vremensko ograničenje ili količina detalja koju umjetnik zaželi. [4,12] 

 

Slika 1-25: Prikaz high poly modela sa poly countom 
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1.7.2. Low poly model 

U low poly izradi modela važno je stvoriti što moguće jednostavan model. Najčešće oni 

najmanji detalji se mogu u potpunosti maknuti sa low poly modela pošto će se oni prilikom bakea 

normal mape pojaviti na modelu. Support loopovi i slični manipulatori koji imaju utjecaj na 

zaglađivanje high poly mesha se također mogu izbrisati pošto to neće previše utjecati na samu 

siluetu modela, a smanjenje poligona prilikom brisanja spomenutih je  strahovito velik. Naravno, 

uz sve navedeno model još uvijek mora biti relativno sličan high poly verziji kako se nebi izgubio 

glavni oblik. [4,12] 

 

Slika 1-26: Prikaz smoothanog low poly modela 
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2. UV mapiranje i teksturiranje 

2.1. UV mapiranje 

UV unwrapping je proces „razmotavanja“ površine modela na 2D teksturu. Polygoni koji 

definiraju geometriju modela polažu se ravno na plohu kao primjerice razmotani model papira koji 

predstavlja površinu modela. [5,6] 

 

Slika 2-1: Prikaz 3D oblika te njega na 2D pozadini 

 

Važno je obratiti pažnju na UV mapu kako bi ona jednolično pokrivala objekt te bi se na taj način 

minimaliziralo rastezanje teksture i drugih sličnih abnormalnosti koje se mogu dogoditi na teksturi 

koja je primjijenjena na površinu modela. [6]  

 

Slika 2-2: Prikaz nejednakih otoka na modelu 
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Nakon što je UV unwrapping gotov 3D artist može započeti postupak teksturiranja na bazi 

složene UV mape koja se exporta iz programa kojeg koristi. [6] 

 

Slika 2-3: Prikaz složene UV mape 

2.2. Teksturiranje 

Teksturiranje modela može daleko poboljšati ili u suprotnom upropastiti kako izgleda model. 

Mape sa teksturama se primjenjuju na površinu modela kako bi se dodali detalji na određeni objekt. 

Postoji mnogo različitih mapa gdje svaka ima drugačiji efekt na sam model, no ovdje će se obraditi 

proces teksturiranja za Physical Based Rendering model, to jest model koji se bazira na metalnim 

ili ne-metalnim teksturama. PBR nastoji precizno simulirati kako osvjetljeni modeli, to jest njihovi 

materijali/teksture i površine, reagiraju prilikom rendera koristeći nekolicinu različitih mapa koje 

im pridodaju važne atribute. Osnovnih petero mapa u PBR tipu teksturiranja su sljedeće: diffuse, 

još zvana i albedo mapa, metalness, ambient occlusion, roughness i normal mapa. [3,8,10] 
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2.2.1. Diffuse mapa 

Diffuse ili albedo mapa je najosnovnija mapa teksturna mapa. Ona definira strikno samo boju 

difuznog svjetla. Ne sadrži nikakve informacije o shadingu pošto taj dio ostale mape  obavljaju. 

Diffuse mapa u sebi nema sjena i i nema nekakve pretjerane razlike u tonalitetu. [3] 

 

Slika 2-4: Prikaz Albedo mape 

2.2.2. Metalness mapa 

Metalness mapa  se bazira na greyscale mapi koja označuje stupanj metalnosti materijala. Ne-

metalne mape se zovu dielektričnima, a metalne mape konduktivnima, jer bi se moglo reči da one 

provode struju. Renderer ove materijale vidi kao da imaju različite reflektivne karakteristike te na 

bazi toga reagira prilikom izrade slike. Kada pixel ima greyscale vrijednost od 1 tada renderer 

smatra da je taj materijal sto-postotno metallic, dok mu nula predstavlja dielektrični materijal. Ove 

mape se najčešće kombiniraju sa ostalim mapama kako bi se uštedjelo na memoriji rezerviranoj 

za teksture. [3] 
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Slika 2-5: Prikaz Metalness mape 

2.2.3. Roughness mapa 

Također, kao i metalness mapa, bazira se na greyscaleu koja na površini predstavlja površinske 

nepravilnosti koje uzrokuju difuziju svjetlosti. Što se tiče roughness mape kod nje vrijednosti 

mjenjaju smjer svjetla, dok jačina svjetlosti ostaje ista. Ako je površina gruba svjetlost će na njoj 

biti manje naglašena i slablja, dok za glađe površine refleksija će biti više fokusirana i istaknutija. 

Vrijednost greyscalea prema nuli označuje da će materijal biti glađi dok bijela boja u roughness 

mapi predstavlja grubost neke površine. [3] 
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Slika 2-6: Prikaz Roughness mape 

2.2.4. Ambient Occlusion mapa 

Mapa ambijentalne okluzije također je greyscale mapa  koja predstavlja okluziju difuznog 

svjetla te se ona u više slučaja bakea iz 3D modela. Definira koliko okolinsko svjetlo ima utjecaj, 

to jest koliko ono dostupno do određenih djelova nekog modela. Time stvara iluziju dubine. Često, 

AO mape se kombiniraju sa albedo mapom, na način da se u nekom engineu spoje zajedno. To je 

takozvana metoda množenja, multiplying method, gdje se boje piksela miješaju što dovodi do 

tamnijih vrijednosti tona piksela. [3] 
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Slika 2-7: Prikaz AO mape 

2.2.5. Normal mapa 

Normal mapa se koristi za to da simulira detalje na površini. RGB mapa gdje svaki od troje 

spomenutih kanala odgovaraju prostornoj dimenziji u tangentnom prostoru. Te koordinatne 

vrijednosti se koriste kako bi se odredila količina svjetla koja se reflektira od površine na nekom 

pixelu. Jedna od daleko najvažnijih mapa koja omogućava umjetniku da izrađuje detalje na 

jednostavnom meshu. [3] 
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Slika 2-8: Prikaz Normal mape 
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3. Baking proces 

Jedan od „tradicionalnih“ načina gdje se detalji sa high poly modela prenose na low poly model 

uz pomoć normal/AO mape koja se kreira iz high poly objekta. Takav način je moguć ako je low 

poly model optimiziran za korištenje u Realtime engine-u. Kod same izrade alat za bake koristit 

će low poly model kao čahuru te će bacati zrake u model više kvalitete. Kada spomenute zrake 

dodirnu model, bilježe se detalji na površini te se spreme u mape koristeći UV mapu od low poly 

modela. Tim načinom bakeanja detalja na low poly objekt se ekstremno smanjuje vrijeme rendera 

te i cijenu izrade samog modela. [3]  

 

Slika 3-1: Prikaz high i low poly modela; prikaz low poly modela sa bakeanim high poly normalama 

 

Prije samog procesa bakea preporuča se triangulirati low poly model i to iz razloga što real time 

engine gdje će se koristiti će pokušati triangulirat model ako nije već bio te tu i tamo može doći 

do pogreške. Važno je spomenuti da mjenjanje otoka UV mape nakon baking procesa nije 

preporučeno pošto se mogu pojaviti abnormalnosti. [3] 
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4. Praktični dio 

4.1. Modeliranje low i high poly verzije modela 

U sljedećem dijelu završnog rada odradit će se koraci izrade game ready asseta. Spomenuti 

proces zahtijeva od osobe poznavanje barem jednog programa za izradu 3D modela, u ovom 

slučaju Autodesk Maya 2019, Marmoset Toolbag 3, te nekih od programa za izradu teksture, 

Quixel Mixer ili Adobe Photoshop i slični. Osim znanja o samoj izradi umjetnik je primoran 

razmišljati unaprijed te konstantno paziti na polycount kako bi bilo moguće da model može 

kvalitetno izgledati i kako bi on mogao biti optimiziran za korištenje u game engineu. 

Autodesk Maya je program za izradu, uređivanje i animiranje 3D modela. Još jedan u nizu od 

programa koji nudi Autodesk, industrija koja izrađuje jedne od najkvalitetnijih softwarea za izradu 

3D, Maya dolazi sa mnogo različitih alata koji pomažu tokom kreacije modela. 

 

Pri izradi bilo kojeg modela počinje se kreiranjem jednog od primitivnih oblika. U ovom 

slučaju koristi se kocka. Kreacija se može izraditi na dvaju načina, Create > Polygon Primitives > 

Cube, dok drugi radi isto, samo je shortcut na alatnoj traci.  

 

 

Slika 4-1: Prikaz kreacije kocke 
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Slika 4-3: Prikaz dodavanja loopova Multi-cut Toolom (1.); 

prikaz ulaska  u Edge mode 

Nakon kreacije dobija se kontrola nad modelom gdje se koristi jedan od četiri osnovna alata:  

Select Tool (Q-kratica) – služi za selektiranje modela, bridova, lica ili točaka  

Move Tool (W-kratica) – služi za pomicanje spomenutih  

Rotate Tool (E-kratica) – služi za rotaciju  

Scale Tool (R-kratica) – služi za skaliranje  

 

Slika 4-2: Prikaz jednog od osnovnih alata 

Sljedeće se na kocki koristi Multi-Cut Tool, kojim se režu polygoni, do njega se dolazi pomoću Mesh 

Tools > Multi-Cut na alatnoj traci. Pritiskom kombinacije CTRL + lijevi klik dodaje se loop oko cijelog 

modela te se nakon toga ulazi u Edge Mode, SHIFT + desni klik, kako bi se mogli odabrati bridovi.  

 

 

 



30 

 

Nakon editiranja i brisanja gornjih bridova ulazi se u Vertex Mode na sličan način kako se 

došlo u Edge Mode, samo se bira Vertex umjesto Edge. Ondje se sa Move Toolom miču točke 

kako bi se dobio željeni izgled. 

Slijedi korištenje jedne od osnovnih funkcija zvane Extrude (CTRL + E, SHIFT + desni klik). 

Ona služi za dodavanje poligona na već postojani mesh tako da odma konektira lica nastala 

prilikom povlačenja  lica prema unutra ili van. To se izradilo kako bi se dobila noga na kojoj 

radničko svjetlo stoji. 

 

Slika 4-4: Prikaz funkcije Extrude 

 

Kreirala se još jedna primitivna kocka koja nakon skaliranja i namještanja prezentira potporu već 

spomenutoj nozi. Ovdje dolazi do problema spajanja njih dviju u jedan, kompliciraniji, objekt. 

Prije nego se mogu točke međusobno spojiti potrebno je ta dva djela ukombinirati u jedan što se 

radi funkcijom Mesh > Combine. 
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Slika 4-5: Prikaz funkcije Combine 

 

Kada se smatraju jednim objektom onda je moguće spojiti vertexe pomoću Mesh Tools > Target 

Weld ili funkcijom Edit Mesh > Merge. 

 

Slika 4-6: Prikaz alata Target Weld 
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Nakon što je spojeno kreira se kocka te se Multi-Cut Toolom režu njezini poligoni. Ukoliko se 

želi razrezati poligon pod točnim kutom od 90* koristi se SHIFT + lijevi klik na željeni brid. 

Također, ako je potrebno prerezati model po samom centru koristi se funkcija CTRL + MMC. 

 

Slika 4-7: Prikaz rezanja pod točnim kutom (1.); prikaz centriranog reza (2.) 

Nakon editiranja spomenute primitive polovica nje se reže te se centrira pivot (Modify > Center 

Pivot) i funkcijom snap to points se povlači na sam kraj modela kao priprema za Mirror funkciju. 

 

Slika 4-8: Prikaz pomicanja pivota 

 

Kada je priprema gotova koristiti se funkcija Mirror (SHIFT + desni klik > Mirror) kako bi se 

zrcalno prenesao ostatak mesha. Nakon korištenja funkcije potrebno je vertexe u sredini spojiti 
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Edit Mesh > Merge naredbom te izbrisati loop nastao u sredini funkcijom CTRL + DEL koja briše 

loop i sve vertexe vezane uz njega. Nakon toga zadnja stvar koju je potrebno uraditi je izbrisati 

povijest izrade modela (Edit > Delete All by Type > History) kako nebi došlo do abnormalnosti 

kod objekta. Kako bi bilo sigurno da je sve u redu može se iskoristiti i funkcija Mesh Cleanup koja 

pokazuje ako postoji koji n-gon na modelu.  

 

Slika 4-9: Prikaz alata Mirror 

 

Slika 4-10: Prikaz brisanja povijesti modela i Cleanup funkcija 
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      Prilikom izrade kapice kod extrude opcije dogodilo se da model ima zamjenjenu prednju i 

stražnju stranu. Kako bi se riješio novonastali problem koristila se funkcija Mesh Display > 

Reverse Normals koji zamjenjuje normale te time i strane na kojima se nalaze. 

 

Slika 4-11: Prikaz funkcije Reverse Normals 

Započinje izrada glavnog dijela gdje se režu i spajaju polygoni nastalih modela. Pošto se neki 

dijelovi moraju klonirati funkcijom držanja SHIFT tipke i pomicanja objekta sa Move Toolom. Za 

namještavanje objekata na njihovo željeno mjesto koristi se Snap to Points opcija. 

 

 

Slika 4-12: Prikaz izrade dijela svjetla i postupak kloniranja 

Prilikom spajanja srednjeg djela koristi se alat Edit Mesh > Bridge kako bi se zatvorio model. 
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Slika 4-13: Prikaz označenih bridova i funkcija Bridge 
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Slijede slike ostatka procesa modeliranja low poly objekta:  
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Nakon što je izrada low poly objekta završena kreira se klon low poly verzije komandom 

SHIFT + D koji će predstavljati budući high poly model. Na njemu se rade funkcije Edit Mesh > 

Bevel, alat kojim se proširuje svaki brid u novo lice, te se time oblikuju rubovi na polygonskoj 

mreži, i manualno dodaju loopovi uz pomoć nekih od funkcija Multi-Cut Toola, koji će držat i 

zaobliti dijelove modela kako bi izgledao visoke kvalitete. 

 

 

 

Slika 4-15: Prikaz mreže i alata Bevel 

Zatim, na dio koji služi za podešavanje visine svjetla dodaju se detalji na high poly verziju 

pošto ona neće kasnije imati efekt na brzinu game engine-a te će se tako model zadržat 

optimiziranim za uporabu. 
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Slika 4-16: Prikaz početnih detalja na dijelu za podešavanje 
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4.2. UV mapiranje 

Nakon što je proces modeliranja završen, slijedi izrada UV mape za low poly model. Pripreme 

koje su potrebne za rad je korištenje funkcije Modify > Freeze Transformations i brisanje povijesti 

izrade. 

 

  

Slika 4-17: Prikaz funkcije Freeze Transformations 

 

Autodesk Maya ima poseban UI unaprijed napravljen za UV mapiranje te se ono preferira za izradu 

UV-a. 

 

 

Slika 4-18: Prikaz promjene sa Maya Classic UI na UV Editing 
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Izrada UV-a se može raditi manualnim rezanjem ili korištenjem alata koji se koriste za 

određene tipove modela (UV > jedan od tipa).  

 

Automatski – Kreira UV otoke iz mesha pokušavajući da nađe najbolji oblik projekcije na 2D 

podlogu 

Plane – Plošni način kreacije UV otoka  

Cylindrical – Cilindrični način kreacije UV otoka  

Spherical – Način kreacije otoka za sferne modele 

 

 

 

 

  

Slika 4-19: Prikaz 

osnovnih alata za izradu UV 

mape 
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Prilikom izrade UV mape događa se to da su neki otoci okrenuti na krivu stranu. Ovdje dolazi 

funkcija Flip koja okreće otok vertikalno ili horizontalno i time rješava nastali problem. 

 

Slika 4-20: Prikaz Flip opcije 

Ukoliko se dijelovi žele spojiti ili razrezati moguće su naredbe:  

Sew – Spaja dijelove UV-a zajedno bez da se miču  

Stitch together – Spaja UV sa micanjem jednog od njih k drugom  

Cut – Reže odabrane djelove nekog otoka  

 

Nakon tih operacija važno koristiti opciju unfold koja razmotava novonastali otok nakon 

kombiniranja. 

 

 

Slika 4-21: Prikaz Sew alata 

 

 

Slika 4-22: Prikaz Stitch Together alata 
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Slika 4-23: Prikaz Cut Tool-a i moment reza 

 

Slika 4-24: Prikaz Unfold opcije 
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Otoci koji su slični u izgledu se mogu posložiti jedan na drugog, no ukoliko nisu 100% isti 

može doći do velikih problema kod teksturiranja. Maya ima funkciju koja nastoji 2 vrlo slična 

otoka napraviti istima koja se zove Match UVs. 

 

 

Slika 4-25: Prikaz korištenja funkcije Match UVs 

 

Texel density je postupak kojim se osigurava da su mesh i teksture iste visine, veličine i dubine. 

UV UI ima funkciju koja to automatski radi na način da iz jednog otoka uzme texel density te ga 

prenese na drugog. 

 

 

Slika 4-26: Prikaz korištenja opcije Set i Get Texel Density 
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Kada je završen dio izrade otoka slijedi slaganje spomenutih u UV mrežu. Jedan način izrade je 

da se dobije izgled UV mape alatom Layout UVs koji automatski slaže otoke u UV prostor te se 

kasnije još manualno sređuje poredak otoka. 

 

Slika 4-27: Prikaz funkcije Layout Uvs (1.); prikaz finalne UV mape 

Nakon izrade UV mape preostalo je izgladiti izgled low i high poly modela što se radi 

naredbom Mesh Display > Soften/Harden Edges (kut smoothinga = 90*). Kada je smooth odrađen 

preostaje posložiti oba dva modela jedan na drugi, ako već nisu unaprijed posloženi, te iskoristiti 

naredbe Freeze Transformations i Delete All by Type > History kako bi se osiguralo da će modeli 

biti bez ikakvih artefakta. Nakon što je sve posloženo potrebno je napraviti File > Export selection, 

u obliku .obj datoteke, na oba modela posebno. 

 

 

Slika 4-28: Prikaz funkcije Soften Edge (1.); prikaz Export funkcije na selektirani mesh (2.) 
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4.3. Bake procedura 

Prvobitno se moraju importat (File > Import) oba modela u MT3 te se nakon toga stvara 

primarna Bake grupa klikom na gumb New Baker. 

 

Slika 4-29: Prikaz Importa modela 

U „Low“ podgrupi slaže se minimalni i maksimalni offset mreže.  

 

Slika 4-30: Prikaz rada sa offsetom 
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Kada je mreža složena, na Bake grupi se odabiru mape koje će se koristiti kod izrade tekstura. 

U ovom slučaju se bakeaju Normal, AO, MatID, Albedo, Roughness, Metalness i radi dodatne 

kontrole Thinckness i Curvature mape. Odabire se opcija bake koja započinje proces izrade mapa. 

Ako neki dio u normal mapi nije najbolje bakean može se manualno popraviti koristeći Paint Offset 

i Paint Skew opcije gdje će se promjene automatski primijeniti na mape. 

 

Slika 4-31: Prikaz klika na Bake gumb i označene mape za bake proces 

4.4. Teksturiranje modela 

Zadnji dio procesa izrade je teksturiranje. Ovdje, kao program za teksturiranje, će se koristiti 

Quixel Mixer. 
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Što se tiče pripreme modela u QM potrebno je otići na Setup > odrediti tip modela Custom 

Mesh te importati low poly model. Nakon toga se otiđe na Layers gdje se posebno importaju mape 

sa teksturama. 

 

Slika 4-32: Prikaz Setup kartice i import modela 

 

Daljnji rad u Quixel Mixeru bazira se na korištenju već postojanih tekstura i tekstura 

novoizrađenih na licu mjesta. Položaj teksture se kontrolira preko maska gdje se dodaju curvature, 

thickness mape ili se dobija kontrola preko position gradienta i sličnih. 

 

Slika 4-33: Prikaz Layer kartice i rad sa teksturama (1.); prikaz maskiranja jedne od tekstura (2.) 
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Kada se završilo sa teksturiranjem, zadnji dio kojeg treba odraditi je napraviti export gotovih 

izteksturiranih mapa tako da se otiđe na Export, odaberu se željene mape i klikne se Export *broj* 

Mapa. 

 

Slika 4-34: Prikaz Exportiranja mapa 
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Finalni izgled modela: 

 

 

Slika 4-35: Prikaz optimiziranog i izteksturiranog modela 
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Slika 4-36: Prikaz detalja-1 

 

Slika 4-37: Prikaz detalja-2 
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Slika 4-38: Prikaz detalja-3 
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5. Zaključak 

Zainteresiranost za izradu 3D modela je sve veća. To iz razloga što 3D osim u industriji 

videoigara se počeo širiti u filmske, medicinske i ostale svrhe. 3D kao takav postaje sve važniji u 

svijetu današnjice. Usprkos svega navedenog još uvijek se najviše koristi u industriji videoigara i 

to se vidi velikim pomakom same kvalitete unazad nekoliko godina i danas.  

 

Autodesk Maya je odličan program za izradu 3D modela uz alate koji pridonose i više nego odličnu 

kontrolu nad modelom, te oni daju umjetniku da izgradi model koliko god kvalitetno i detaljno 

želi. Također je važno spomenuti MT3 I QM od novonastalih programa koji inače dugoročni 

proces izrade game ready asseta vremenski jako smanjuju.  

 

Najbitnija stvar kod izrade modela je shvatiti sam princip, kako i od kojeg primitivnog oblika 

započeti, te kako se nositi i riješiti probleme koji se događaju prilikom izrade. Najvažnija stvar 

nakon tijeka izrade je paziti da model ima što manji polycount koje ga zauzvrat čini optimiziranim. 

Iako je sama ideja o modeliranju jednostavna potrebno je mnogo uloženog truda i vremena kako 

bi se savladao 3D.  

 

Ovaj završni rad nastao je kako bi se riješila problematika izrade i optimizacije 3D modela, te kako 

bi se prošle same osnove 3D modeliranja, UV mapiranja, kako bi se više objasnio proces bakeanja 

normala i na kraju teksturiranja te bi se time pokazale sve naučene vještine.  

 

 

 

 

 

 

 

 

U Varaždinu, 

30. rujna 2020.
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